popper.js by: FezVrasta
  • 596 total downloads
  • Latest version: 1.16.1
A kickass library to manage your poppers
Portable.BouncyCastle by: Claire Novotny
  • 1.024k total downloads
  • Latest version: 1.9.0
  • bouncycastle cryptography encryption security
BouncyCastle portable version with support for .NET 4, .NET Standard 2.0
Portable.BouncyCastle-Signed by: Mark Junker
  • 39 total downloads
  • Latest version: 1.7.0.2
  • bouncycastle cryptography encryption security PCL wp8 wpa81 net4 sl5 monotouch monoandroid xamarin
BouncyCastle.Crypto is a cryptography API providing: -Generation and parsing of PKCS#12 files. -X.509: Generators and parsers for V1 and V3 certificates, V2 CRLs and attribute certificates. -PBE algorithms supported by PBEUtil: PBEwithMD2andDES-CBC, PBEwithMD2andRC2-CBC, PBEwithMD5andDES-CBC, PBEwithMD5andRC2-CBC, PBEwithSHA1andDES-CBC, PBEwithSHA1andRC2-CBC, PBEwithSHA-1and128bitRC4, PBEwithSHA-1and40bitRC4, PBEwithSHA-1and3-keyDESEDE-CBC, PBEwithSHA-1and2-keyDESEDE-CBC, PBEwithSHA-1and128bitRC2-CBC, PBEwithSHA-1and40bitRC2-CBC, PBEwithHmacSHA-1, PBEwithHmacSHA-224, PBEwithHmacSHA-256, PBEwithHmacRIPEMD128, PBEwithHmacRIPEMD160, and PBEwithHmacRIPEMD256. -Signature algorithms supported by SignerUtilities: MD2withRSA, MD4withRSA, MD5withRSA, RIPEMD128withRSA, RIPEMD160withRSA, RIPEMD256withRSA, SHA-1withRSA, SHA-224withRSA, SHA-256withRSAandMGF1, SHA-384withRSAandMGF1, SHA-512withRSAandMGF1, SHA-1withDSA, and SHA-1withECDSA. -Symmetric key algorithms: AES, Blowfish, Camellia, CAST5, CAST6, DESede, DES, GOST28147, HC-128, HC-256, IDEA, NaccacheStern, RC2, RC4, RC5-32, RC5-64, RC6, Rijndael, Serpent, Skipjack, TEA/XTEA, Twofish, and VMPC. -Symmetric key modes: CBC, CFB, CTS, GOFB, OFB, OpenPGPCFB, and SIC (or CTR). -Symmetric key paddings: ISO10126d2, ISO7816d4, PKCS#5/7, TBC, X.923, and Zero Byte. -Asymmetric key algorithms: RSA (with blinding), ElGamal, DSA, ECDSA. -Asymmetric key paddings/encodings: ISO9796d1, OAEP, and PKCS#1. -Digests: GOST3411, MD2, MD4, MD5, RIPEMD128, RIPEMD160, RIPEMD256, RIPEMD320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, Tiger, and Whirlpool. -Signer mechanisms: DSA, ECDSA, ECGOST3410, GOST3410, ISO9796d2, PSS, RSA. -Key Agreement: Diffie-Hellman and EC-DH. -Macs: CBCBlockCipher, CFBBlockCipher, GOST28147, HMac, and ISO9797 Alg. 3. -PBE generators: PKCS#12, and PKCS#5 - schemes 1 and 2. -OpenPGP (RFC 2440) -Cryptographic Message Syntax (CMS, RFC 3852), including streaming API. -Online Certificate Status Protocol (OCSP, RFC 2560). -Time Stamp Protocol (TSP, RFC 3161). -TLS/SSL Client with support for client side authentication. Support for .NET 4, Windows Phone 8, Windows Phone App 8.1, Windows 8, Silverlight 5, MonoTouch, MonoAndroid
Portable.ConcurrentDictionary by: Stef Heyenrath
  • 85 total downloads
  • Latest version: 1.0.4
  • Dictionary ConcurrentDictionary Collections System.Collections.Concurrent
This is a .NET Standard 1.0, .NET 2.0, .NET 3.5, Silverlight 5.0 and Windows Phone Silverlight 8.0 & 8.1 backport from System.Collections.Concurrent.ConcurrentDictionary as defined in .NET Core
Portable.JWT by: Mitja Bombac
  • 30 total downloads
  • Latest version: 1.0.5
  • jwt portable json signing hs256 hs384 hs512 key password based encryption
JWT (JSON Web Token) Portable Implementation for .NET 4.5+ (Public Domain). Supported algorithms: HMAC signatures with HS256, HS384 and HS512.
Portable.System.DateTimeOnly by: Oleg Rakhmatulin
  • 205 total downloads
  • Latest version: 9.0.2
  • DateOnly TimeOnly
DateOnly and TimeOnly types for .NET versions before 6.0
postgrest-csharp by: Joseph Schultz <joseph@acupofjose.com>
  • 1.056k total downloads
  • Latest version: 3.5.1
  • supabase postgrest
Postgrest-csharp is written primarily as a helper library for supabase/supabase-csharp, however, it should be easy enough to use outside of the supabase ecosystem. The bulk of this library is a translation and c-sharp-ification of the supabase/postgrest-js library.
Pragmastat by: Andrey Akinshin
  • 824 total downloads
  • Latest version: 14.0.1
  • statistics
Pragmatic Statistical Toolkit
prometheus-net by: andrasm qed- lakario sandersaares
  • 5.818k total downloads
  • Latest version: 8.2.1
  • metrics prometheus
.NET client library for the Prometheus monitoring and alerting system
protobuf-net by: Marc Gravell
  • 2.221k total downloads
  • Latest version: 3.4.40
  • binary serialization protobuf
Provides simple access to fast and efficient "Protocol Buffers" serialization from .NET applications
protobuf-net.Core by: Marc Gravell
  • 1.426k total downloads
  • Latest version: 3.4.30
  • binary serialization protobuf
The protobuf-net serialization engine and build-time tooling; most projects should reference protobuf-net, which adds the runtime type model
PtgPdfCore.runtime.android by: patagames.com
  • 32 total downloads
  • Latest version: 5.0.6
  • native runtime android-x64 android-x86 android-arm android-arm64 pdf pdfium ptg patagames
Runtime native library assets for the Pdfium.Net SDK package (id:pdfium.net.sdk) - android-x64, android-x86, android-arm, android-arm64.
PtgPdfCore.runtime.linux by: patagames.com
  • 29 total downloads
  • Latest version: 5.0.6
  • native runtime linux-x64 linux-x86 linux-arm linux-arm64 pdf pdfium ptg patagames
Runtime native library assets for the Pdfium.Net SDK package (id:pdfium.net.sdk) - linux-x64, linux-x86, linux-arm, linux-arm64.
PtgPdfCore.runtime.linux-musl by: patagames.com
  • 34 total downloads
  • Latest version: 5.0.6
  • native runtime linux-musl-x64 linux-musl-x86 linux-musl-arm linux-musl-arm64 pdf pdfium ptg patagames
Runtime native library assets for the Pdfium.Net SDK package (id:pdfium.net.sdk) - linux-musl-x64, linux-musl-x86, linux-musl-arm, linux-musl-arm64.
PtgPdfCore.runtime.osx by: patagames.com
  • 40 total downloads
  • Latest version: 5.0.7
  • native runtime osx pdf pdfium ptg patagames
Runtime native library assets for the Pdfium.Net SDK package (id:pdfium.net.sdk) - universal binary x86_64, arm64.
PtgPdfCore.runtime.win by: patagames.com
  • 38 total downloads
  • Latest version: 5.0.6
  • native runtime win-x64 win-x86 pdf pdfium ptg patagames
Runtime native library assets for the Pdfium.Net SDK package (id:pdfium.net.sdk) - win-x64, win-x86.
PuppeteerSharp by: Darío Kondratiuk
  • 1.804k total downloads
  • Latest version: 25.15.0
  • headless chrome puppeteer
Headless Browser .NET API
QRCoder by: Raffael Herrmann Shane Krueger
  • 1.058k total downloads
  • Latest version: 1.8.0
  • c# csharp qr qrcoder qrcode qr-generator qr-code-generator
QRCoder is a simple library, written in C#.NET, which enables you to create QR codes.
QRCoder.Core by: Afonso Dutra Nogueira Filho
  • 57 total downloads
  • Latest version: 2.0.0
  • c# csharp qr qrcoder qrcode qr-generator qr-code-generator Core NET
QRCoder.Core, written in C#.NET, which enables you to create QR codes.
QRCoder-ImageSharp by: Raffael Herrmann Joerg Plenert
  • 101 total downloads
  • Latest version: 0.10.0
  • c# csharp qr qrcoder qrcode qr-generator qr-code-generator
QRCoder is a simple library, written in C#.NET, which enables you to create QR codes. Based on ImageSharp to provide plattform independency.